Option C - With Next Hop Unchanged

Hi All,

I need help in troubleshooting Option C with NH-Unchanged.
I was following KB videos, and till that point everything was working fine.

After adding other PE routers to access-list and assign NH-Unchanged to the RR, I am not getting Labels for the other PE’s I am still getting the Label for 10.7.7.7, and now the topology is broken and R9 can not ping R11.

Let me know what is required to troubleshoot this issue

======
R4#sh ip bg | be Net
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.1/32 192.1.100.1 11 32768 ?
*> 10.2.2.2/32 192.1.100.2 11 32768 ?
*> 10.3.3.3/32 192.1.34.3 11 32768 ?

  • 10.5.5.5/32 192.1.48.8 20 0 200 ?
    *>i 10.7.7.7 0 100 0 200 ?
  • 10.6.6.6/32 192.1.48.8 20 0 200 ?
    *>i 10.7.7.7 0 100 0 200 ?
    *> 10.7.7.7/32 192.1.48.8 20 0 200 ?

R8#sh ip bgp | b Net
Network Next Hop Metric LocPrf Weight Path
*>i 10.1.1.1/32 10.3.3.3 0 100 0 100 ?

  •                 192.1.48.4              11             0 100 ?
    

*>i 10.2.2.2/32 10.3.3.3 0 100 0 100 ?

  •                 192.1.48.4              11             0 100 ?
    

*> 10.3.3.3/32 192.1.48.4 11 0 100 ?
*> 10.5.5.5/32 192.1.200.5 20 32768 ?
*> 10.6.6.6/32 192.1.200.6 20 32768 ?
*> 10.7.7.7/32 192.1.78.7 20 32768 ?

R3#sh bgp vpnv4 un al | b Net
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1
*>i 10.9.9.0/24 10.1.1.1 0 100 0 65009 i
*>i 10.10.10.0/24 10.2.2.2 0 100 0 65010 i
*>i 10.13.13.0/24 10.4.4.4 0 100 0 65013 i
Route Distinguisher: 200:1
*> 10.11.11.0/24 10.5.5.5 0 200 65011 i
*> 10.12.12.0/24 10.6.6.6 0 200 65012 i

  • 10.14.14.0/24 10.8.8.8 0 200 65014 i

R7#sh bgp vpnv4 un all | b Net
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1
*> 10.9.9.0/24 10.1.1.1 0 100 65009 i
*> 10.10.10.0/24 10.2.2.2 0 100 65010 i

  • 10.13.13.0/24 10.4.4.4 0 100 65013 i
    Route Distinguisher: 200:1
    *>i 10.11.11.0/24 10.5.5.5 0 100 0 65011 i
    *>i 10.12.12.0/24 10.6.6.6 0 100 0 65012 i
    *>i 10.14.14.0/24 10.8.8.8 0 100 0 65014 i

R4#sh mpls fo
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
4000 Pop Label 10.3.3.3/32 87083 Et0/1 192.1.34.3
4001 Pop Label 10.2.2.2/32 0 Et0/0 192.1.100.2
4002 Pop Label 10.1.1.1/32 0 Et0/0 192.1.100.1
4003 Pop Label 192.1.23.0/24 0 Et0/1 192.1.34.3
Pop Label 192.1.23.0/24 0 Et0/0 192.1.100.2
4004 Pop Label 192.1.13.0/24 0 Et0/1 192.1.34.3
Pop Label 192.1.13.0/24 0 Et0/0 192.1.100.1
4005 No Label 10.13.13.0/24[V] 0 Et0/2 192.168.40.13
4006 8002 10.7.7.7/32 89247 Et0/3 192.1.48.8
4007 Pop Label 192.1.48.8/32 0 Et0/3 192.1.48.8
4008 No Label 10.5.5.5/32 0 Et0/3 192.1.48.8
4009 No Label 10.6.6.6/32 0 Et0/3 192.1.48.8
R4#

R8#sh mpls for
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
8000 Pop Label 10.6.6.6/32 0 Et0/0 192.1.200.6
8001 Pop Label 10.5.5.5/32 0 Et0/0 192.1.200.5
8002 Pop Label 10.7.7.7/32 81380 Et0/1 192.1.78.7
8003 Pop Label 192.1.67.0/24 0 Et0/1 192.1.78.7
Pop Label 192.1.67.0/24 0 Et0/0 192.1.200.6
8004 Pop Label 192.1.57.0/24 0 Et0/1 192.1.78.7
Pop Label 192.1.57.0/24 0 Et0/0 192.1.200.5
8005 No Label 10.14.14.0/24[V] 0 Et0/2 192.168.80.14
8006 4000 10.3.3.3/32 93573 Et0/3 192.1.48.4
8007 Pop Label 192.1.48.4/32 0 Et0/3 192.1.48.4
8008 No Label 10.1.1.1/32 0 Et0/3 192.1.48.4
8009 No Label 10.2.2.2/32 0 Et0/3 192.1.48.4
R8#

R1#sh bgp vpnv4 un all | b Net
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf A)
*> 10.9.9.0/24 192.168.10.9 0 0 65009 i
*>i 10.10.10.0/24 10.2.2.2 0 100 0 65010 i
*>i 10.11.11.0/24 10.5.5.5 0 100 0 200 65011 i
*>i 10.12.12.0/24 10.6.6.6 0 100 0 200 65012 i
*>i 10.13.13.0/24 10.4.4.4 0 100 0 65013 i
Route Distinguisher: 200:1
*>i 10.11.11.0/24 10.5.5.5 0 100 0 200 65011 i
*>i 10.12.12.0/24 10.6.6.6 0 100 0 200 65012 i

R5#sh bgp vpnv4 un all | b Net
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1
*>i 10.9.9.0/24 10.1.1.1 0 100 0 100 65009 i
*>i 10.10.10.0/24 10.2.2.2 0 100 0 100 65010 i
Route Distinguisher: 200:1 (default for vrf A)
*>i 10.9.9.0/24 10.1.1.1 0 100 0 100 65009 i
*>i 10.10.10.0/24 10.2.2.2 0 100 0 100 65010 i
*> 10.11.11.0/24 192.168.50.11 0 0 65011 i
*>i 10.12.12.0/24 10.6.6.6 0 100 0 65012 i
*>i 10.14.14.0/24 10.8.8.8 0 100 0 65014 i
R5#

R9#traceroute 10.11.11.11 so lo0 num pro 1
Type escape sequence to abort.
Tracing the route to 10.11.11.11
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.10.1 1 msec
2 *
3

Let me know if anything else needed to troubleshoot this issue.

Regards,
Mahir

kill the MP-eBGP neighborship between ASBR’s R4 and R8, u need the MP-eBGP neighborship between RR’s ( R3 and R7)

Once u kill the neighborship

  • 10.5.5.5/32 192.1.48.8 20 0 200 ? -------------------------- should be the ONLY best path
    *>i 10.7.7.7 0 100 0 200 ? ----------------------------- xxxxxxxxxxxxx gone
  • 10.6.6.6/32 192.1.48.8 20 0 200 ? --------------------------- should be the ONLY best path
    *>i 10.7.7.7 0 100 0 200 ?----------------------------xxxxxxxxxxxxxxx gone
    *> 10.7.7.7/32 192.1.48.8 20 0 200 ?

Hi Manjinder_Singh,

There is no MP-eBGP between R4 and R8, please find belor the BGP config of both routers.

====
R4

router bgp 100
bgp log-neighbor-changes
redistribute ospf 1 route-map O2B
neighbor 10.3.3.3 remote-as 100
neighbor 10.3.3.3 update-source Loopback10
neighbor 192.1.48.8 remote-as 200
neighbor 192.1.48.8 send-label
!
address-family vpnv4
neighbor 10.3.3.3 activate
neighbor 10.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf A
neighbor 192.168.40.13 remote-as 65013
neighbor 192.168.40.13 activate
exit-address-family

R8

router bgp 200
bgp log-neighbor-changes
redistribute isis level-2 route-map I2B
neighbor 10.7.7.7 remote-as 200
neighbor 10.7.7.7 update-source Loopback10
neighbor 192.1.48.4 remote-as 100
neighbor 192.1.48.4 send-label
!
address-family vpnv4
neighbor 10.7.7.7 activate
neighbor 10.7.7.7 send-community extended
exit-address-family
!
address-family ipv4 vrf A
neighbor 192.168.80.14 remote-as 65014
neighbor 192.168.80.14 activate
exit-address-family

Regards,
Mahir

Can you share the access lists configs on R4 and R8 both 1 and 2 … and RR configs on R3 and R7 ?
Thanks